Facing gdb error in STM32 Cube IDE

Hello Team
We are facing some issues when trying to debug. It’s displaying as Error in final sequence, Fail to start GDB server. We are facing same error in 2 micro controllers with same series STM32NUCLEO401RE and also in STLinkV2 USB debbuger type. Here we are attaching the screenshot of what the error we faced
Kindly go through once and try to help out us.
Thank you

1 Like

Have you installed the driver for ST-link? Check if it’s visible in the device manager??

1 Like

Can u please share proper STLinkV2 driver if possible.

The STM32Cube IDE package comes with the driver. Their is no need to install it unless uninstalled. Can you make sure if STLINK is visible in the device manager??

Yes STLink is visible in device manager.But issue remains same.

In windows, go to start button and search Device manager. In the Device Manager window, go to Universal Serial Bus. See, if Stlink is visible there.

Yes STLink is visible in device manager.

This issue mostly happens when their is no power on the nucleo board. Are you using the onboard ST-link or seperate one? How you power your board??

Also, In STM32CubeIDE, choose Help > ST-LINK Upgrade and click Open in update mode and then Upgrade to upgrade the ST-link firmware. See if you are able to upgrade the firmware.

I am having 2 type of STM32 boards.

  1. STM32F401RE board having onboard debugger.

  2. STM32F407VET6 board,for this connecting external debugger(STLinkV2).

For both boards same issue.

Thank you.

We are followed your steps, but issue remains same

Sorry for the late response. Can you confirm that the light on the STM32F401RE is ON. Can you send a picture of the whole setup if possible?? The issue might be related to power.


I suspect the issue is with the USB cabe. Can you try changing the cable and see if its working?

Yes, we tried with different cables issue remains same.

Thank you


Can you show the entire pin configuration picture please?

Have you tried updating the firmware as I mentioned in previous post??

Yes, we updated firmware aslo.

Thank you

Open Device Manager in windows, find your STM32 STLink device, double-click to open the Properties dialog. Then click “Update Driver”, then “Browse my computer for driver software”, then “Let me pick from a list of available drivers on my computer”, and you should see something like this.


From their choose, the STlink dongle driver and click next. See if its working.

I will check and update to you.

Thank you


Can you show the entire pinout configuration picture ?