Facing gdb error in STM32 Cube IDE


Sorry for late reply team is busy with projects.

We tried everything as your side mentioned in above post and issue remains same.

Same issue getting on one more board STM32F407VG having onboard STLink.

Please provide quick solution.

Thank you.

I asked you for a pinout screen configuration from cubeIDE.

It seems to me that you changed board, Didn’t you?

1 Like

I think @Nysse mentioned a valid point. The STM32 board selected in the IDE is different from which you are using. You’re have connected STM32F407G board to your PC but you have chosen STM32L433RCT chip in your IDE. You have to create a new project with your board/chip.



Issue solved. thank you very much guy’s.

1 Like

Yeb, I’ve faced this problem last week, and my solving is that I try to update firmware via STM32programing. Try this bro.

1 Like

We have had this problem a while back. I didn’t get to the bottom of the issue, but installing the latest version of Cube IDE fixed it for me and another of our engineers

1 Like